
CPE 323: Laboratory Assignment #1 
Getting Started with  

the MSP430 IAR Embedded Workbench 
 
by Alex Milenkovich, milenkovic@computer.org 
 
Objectives:  This tutorial will help you get started with the MSP30 IAR Embedded Workbench 
and includes the following topics:  

 Creating an application project 
 Debugging using the IAR C-SPY® Debugger 

 
Note: This tutorial is adapted from the MSP430 IAR Embedded Workbench® IDE User Guide 
and readers are referred to this document for more information.   

1. Creating an Application Project 
This chapter introduces you to the IAR Embedded Workbench integrated development 
environment (IDE). The tutorial demonstrates a typical development cycle and shows how you 
use the compiler and the linker to create a small application for the MSP430 microcontroller -- 
including, creating a workspace, setting up a project with C source files, and compiling and 
linking your application.   

1.1. Creating a New Workspace 
Using the IAR Embedded Workbench IDE, you can design advanced project models.  For more 
information read the MSP430 IAR Embedded Workbench® IDE User Guide.  Here, we will 
walk through a relatively simple project with several source files.  
 
Step 1.  Create a working directory (e.g., projects, and then lab1).  
 
Step 2.  Copy the following source files (lab1factoriel_main.c, twofact.c) to your working 
directory projects/lab1 (go to files are available in Angel:Lessons:Laboratory 
Assignments:Lab1).   
 
Step 3.  Create a new workspace window.  
Before you can create your project you must first create a workspace.  When you start the IAR 
you will see the screen as shown in Figure 1. Press Cancel. Choose File>New>Workspace. Now 
you are ready to create a project and add it to the workspace.  
 



 
Figure 1.  Embedded Workbench Startup. 

 

1.2. Setting Up a New Project 
Step 1.  Create a new project.  
1.1. To create a new project, choose Project>Create New Project. The Create New Project 
dialog box appears (Figure 2), which lets you base your new project on a project template.  Make 
sure the Tool chain is set to MSP430, and click OK. For this tutorial, select the project template 
Empty project, which simply creates an empty project that uses default project settings. 
 

 
Figure 2.  Create New Project dialog box. 

 
In the standard Save As dialog box that appears, specify where you want to place your project 
file, that is, in your newly created projects/lab1 directory. Type the project name (e.g., lab1t) in 
the File name box, and click Save to create the project. The project will appear in the Workspace 
window.   
 
By default two build configurations are created: Debug and Release. In this tutorial only the 
Debug configuration is used. You may choose the build configuration from the drop-down menu 
at the top of the window. The asterisk in the project name indicates that there are changes that 
have not been saved. 
 



A project file—with the filename extension ewp—will be created in the projects directory, not 
immediately, but later on when you save the workspace. This file contains information about 
your project-specific settings, such as build options.    
 
1.2. Choose File>Save Workspace and specify where you want to place your workspace file.  In 
this tutorial, you should place it in your projects directory. Type tutorials in the File name box, 
and click Save to create the new workspace.   
 
A workspace file—with the filename extension eww—has now been created in the projects 
directory. This file lists all projects that you will add to the workspace. Information related to the 
current session, such as the placement of windows and breakpoints is located in the files created 
in the projects\lab1\settings directory. 
 
Step 2.  Adding Files to the Project.  
This tutorial uses the source files lab1factoriel_main.c and twofact.c. 

 The lab1factoriel_main.c application is a simple program that calls two functions 
calculating factoriel of an interger input. The first one ifact returns the integer result, and 
the second one lifact returns the long integer type. Only standard features of the C 
language are used and the results are printed on the stdout (Terminal I/O in this example).  

 The twofact.c application contains factoriel functions ifact and lifact. 
 
In the Workspace window, select the destination to which you want to add a source file; a group 
or, as in this case, directly to the project. 
 
Choose Project>Add Files to open a standard browse dialog box. Locate the files 
lab1factoriel_main.c and twofact.c, select them in the file selection list, and click Open to add 
them to the lab1t project (Figure 3). 
 
 

 
Figure 3.  Adding files to lab1t. 

 
Step 3.  Setting Project Options.  
Now you will set the project options. For application projects, options can be set on all levels of 
nodes. First you will set the general options to suit the processor configuration in this tutorial. 



Because these options must be the same for the whole build configuration, they must be set on 
the project node.  
 
 
3.1. Select the project folder icon lab1t - Debug in the Workspace window and choose 
Project>Options. 
The Target options page in the General Options category is displayed (Figure 4). 
 

    
Figure 4.  Setting general options. 

Verify the following settings: 
Page      Setting 
Target Device:    msp430F149 
Output Output file:    Executable 
Library Configuration Library:  Normal DLIB 
 
Select Library Options tab and select Small for Printf and Scanf formatters. 
 
3.2. Select C/C++ Compiler in the Category list to display the compiler option pages (Figure 5). 
 

 
Figure 5.  Setting C/C++ compiler options. 



Verify the following settings: 
Page      Setting 
Optimizations     Optimizations, Size: None (Best debug support) 
Output     Generate debug information 
List      Output list file/Assembler mnemonics  
 
3.3. Click OK to set the options you have specified.  
Note: It is possible to customize the amount of information to be displayed in the Build messages 
window. In this tutorial, the default setting is not used. Thus, the contents of the Build messages 
window on your screen might differ from the screen shots.  
The project is now ready to be built. 
 

1.3. Compiling and linking the application 
 
You can now compile and link the application. You should also create a compiler list file 
and a linker map file and view both of them. 
 
Step 1.  Compiling the source files.   
To compile the file twofact.c, select it in the Workspace window.  
1.1. Choose Project>Compile. Alternatively, click the Compile button in the toolbar or choose 
the Compile command from the context menu that appears when you right-click on the selected 
file in the Workspace window. The progress will be displayed in the Build messages window. 
 
1.2. Compile the file lab1factoriel_main.c in the same manner. 
 
The IAR Embedded Workbench IDE has now created new directories in your project directory. 
Because you are using the build configuration Debug, a Debug directory has been created 
containing the directories List, Obj, and Exe: 

 The List directory is the destination directory for the list files. The list files have the 
extension lst. 

 The Obj directory is the destination directory for the object files from the compiler 
and the assembler. These files have the extension r43 and will be used as inputs to the 
IAR XLINK Linker. 

 The Exe directory is the destination directory for the executable file. It has the 
extension d43 and will be used as an input to the IAR C-SPY® Debugger. Note that 
this directory will be empty until you have linked the object files. 

 
1.3. Click on the plus signs in the Workspace window to expand the view (Figure 6). As you can 
see, IAR Embedded Workbench has also created an output folder icon in the Workspace window 
containing any generated output files. All included header files are displayed as well, showing 
the dependencies between the files. 
 



 
Figure 6.  Workspace window after compilation. 

 
 
 
Step 2.  Viewing the List file.   
Now examine the compiler list file and notice how it is automatically updated when you, as in 
this case, will investigate how different optimization levels affect the generated code size.  
 
2.1. Open the list file twofact.lst by double-clicking it in the Workspace window. Examine the 
list file, which contains the following information: 

 The header shows the product version, information about when the file was created, 
and the command line version of the compiler options that were used 

 The body of the list file shows the assembler code and binary code generated for each 
statement. It also shows how the variables are assigned to different segments 

 The end of the list file shows the amount of stack, code, and data memory required, 
and contains information about error and warning messages that might have been 
generated. 

 
Notice the amount of generated code at the end of the file and keep the file open. It is (assuming 
you use no optimizations):  
   Segment part sizes: 
 
     Function/Label Bytes 
     -------------- ----- 
     ifact            50 



     lifact          102 
 
  
 152 bytes in segment CODE 
  
 152 bytes of CODE memory 
 
2.2. Choose Tools>Options to open the IDE Options dialog box and click the Editor tab. Select 
the option Scan for Changed Files. This option turns on the automatic update of any file open in 
an editor window, such as a list file. Click the OK button. 
 

 
Figure 7.  Setting the option Scan for Changed Files. 

 
2.3. Select the file twofact.c in the Workspace window. Open the C/C++ Compiler options 
dialog box by right-clicking on the selected file in the Workspace window.  
Click the Optimizations tab and select the Override inherited settings option. Choose High from 
the Optimizations drop-down list. Click OK. 
Notice that the options override on the file node is indicated in the Workspace window. 
 
2.4. Compile the file lab1factoriel_main.c. Now you will notice two things. First, note the 
automatic updating of the open list file due to the selected option Scan for Changed Files. 
Second, look at the end of the list file and notice the effect on the code size due to the increased 
optimization. It is:  
     Function/Label Bytes 
     -------------- ----- 
     ifact            48 
     lifact           96 
 
  
 144 bytes in segment CODE 
  
 144 bytes of CODE memory 
 



2.5. For this tutorial, the optimization level None should be used, so before linking the 
application, restore the default optimization level. Open the C/C++ Compiler options dialog box 
by right-clicking on the selected file in the Workspace window.  
 
Step 3.  Linking the application.   
Now you should set up the options for the IAR XLINK Linker.  
 
3.1. Select the project folder icon lab1t - Debug in the Workspace window and choose 
Project>Options (Figure 8). Then select Linker in the Category list to display the XLINK option 
pages. For this tutorial, default factory settings are used. However, pay attention to the choice of 
output format and linker command file. 
 

 
Figure 8.  XLINK options dialog box. 

 
Output format 
It is important to choose the output format that suits your purpose. You might want to load it to a 
debugger—which means that you need output with debug information. In this tutorial you will 
use the default output options suitable for the C-SPY debugger—Debug information for C-SPY, 
With runtime control modules, and With I/O emulation modules—which means that some low-
level routines will be linked that direct stdin and stdout to the Terminal I/O window in the C-
SPY Debugger. You find these options on the Output page.  
Alternatively, in your real application project, you might want to load the output to a PROM 
programmer—in which case you need an output format without debug information, such as Intel-
hex or Motorola S-records. 
 
Linker command file 
In the linker command file, the XLINK command line options for segment control are used for 
placing segments. It is important to be familiar with the linker command file and placement of 
segments. You can read more about this in the MSP430 IAR C/C++ Compiler Reference Guide. 
The linker command file templates supplied with the product can be used as is in the simulator, 
but when using them for your target system you might have to adapt them to your actual 
hardware memory layout. You can find supplied linker command files in the config directory. In 
this tutorial you will use the default linker command file, which you can see on the Config page. 



If you want to examine the linker command file, use a suitable text editor, such as the IAR 
Embedded Workbench editor, or print a copy of the file, and verify that the definitions match 
your requirements. 
 
Linker map file 
By default no linker map file is generated. To generate a linker map file, click the List tab and 
select the options Generate linker listing, Segment map, and Module map. 
 
3.2. Click OK to save the XLINK options.  Now you should link the object file, to generate code 
that can be debugged. 
 
3.3. Choose Project>Make. The progress will as usual be displayed in the Build messages 
window. The result of the linking is a code file lab1t.d43 with debug information and a map file 
lab1t.map. 
 
Step 4.  Viewing the map file.   
Examine the file lab1t.map to see how the segment definitions and code were placed in memory. 
These are the main points of interest in a map file: 

 The header includes the options used for linking. 
 The CROSS REFERENCE section shows the address of the program entry. 
 The RUNTIME MODEL section shows the runtime model attributes that are used. 
 The MODULE MAP shows the files that are linked. For each file, information about the 

modules that were loaded as part of your application, including segments and global 
symbols declared within each segment, is displayed. 

 The SEGMENTS IN ADDRESS ORDER section lists all the segments that constitute 
your application. 

 
The lab1t.d43 application is now ready to be run in the IAR C-SPY Debugger. 
 



2. Debugging using the IAR C-SPY® Debugger 
 
This section continues the development cycle started in the previous section and explores the 
basic features of the IAR C-SPY Debugger.  
 

2.1. Starting The C-SPY Debugger 
Before starting the IAR C-SPY Debugger you must set a few C-SPY options. 
 
Step 1. Choose Project>Options and then the Debugger category (Figure 9). On the Setup page, 
make sure that you have chosen Simulator from the Driver drop-down list and that Run to main 
is selected. Click OK. 
 

 
Figure 9.  Setting the debugger options. 

 
 
Step 2. Choose Project>Debug. Alternatively, click the Debugger button in the toolbar. The IAR 
C-SPY Debugger starts with the lab1t.d43 application loaded. In addition to the windows already 
opened in the Embedded Workbench, a set of C-SPY-specific windows are now available 
(Figure 10). 
 
Make sure the following windows and window contents are open and visible on the screen: the 
Workspace window with the active build configuration tutorials – lab1t, the editor window with 
the source files lab1factoriel_main.c and twofact.c, and the Debug Log window.  



 
Figure 10.  The C-SPY debugger main window. 

 
 

2.2. Inspecting source statements 
To inspect the source statements, double-click the file lab1factoriel_main.c in the Workspace 
window. 
 
Step 1. With the file lab1factoriel_main.c displayed in the editor window, first step over with the 
Debug>Step Over command.  
Alternatively, click the Step Over button on the toolbar.  
 
Step 2. Choose Debug>Step Into to step into the functions ifact and lifact. 
Alternatively, click the Step Into button on the toolbar.  
At source level, the Step Over and Step Into commands allow you to execute your application a 
statement or instruction at a time. The Step Into continues stepping inside function or subroutine 
calls, whereas Step Over executes each function call in a single step. When the Step Into is 
executed you will notice that the active window changes to twofact.c as the functions are located 
in this file. 
 
Step 3. Use the Step Into command until you reach the end of the ifact function.  



 
Step 4. You can also step on a statement level. Choose the Debug>Next statement to execute one 
statement at a time. Alternatively, click the Next statement button on the toolbar. Notice how this 

command differs from the Step Over and the Step Into commands.  
Explore other options (Step out, Run to, etc).  
 

2.3. Inspecting Variables 
C-SPY allows you to watch variables or expressions in the source code, so that you can keep 
track of their values as you execute your application. You can look at a variable in a number of 
ways; for example by pointing at it in the source window with the mouse pointer, or by opening 
one of the Locals, Watch, Live Watch, or Auto windows.  
 
Note: When optimization level None is used, all non-static variables will live during their entire 
scope and thus, the variables are fully debuggable. When higher levels of optimizations are used, 
variables might not be fully debuggable. 
 
Using the Auto Window  
Choose View>Auto to open the Auto window. Keep stepping to see how the values change. 
 

 
Figure 11.  Inspecting variables in the Auto window. 

 

2.4. Setting a watchpoint 
Next you will use the Watch window to inspect variables. 
Choose View>Watch to open the Watch window. Notice that it is by default grouped together 
with the currently open Auto window; the windows are located as a tab group. 
 
Set a watchpoint on the variable i using the following procedure: Click the dotted rectangle in the 
Watch window. In the entry field that appears, type i and press the Enter key. You can also drag 
a variable from the editor window to the Watch window. 
 
 



 
Figure 12.  Watching variables in the Watch window. 

 
 

Execute some more steps to see how the values of i and change. 
 
To remove a variable from the Watch window, select it and press Delete. 
 

2.5. Setting And Monitoring Breakpoints 
The IAR C-SPY Debugger contains a powerful breakpoint system with many features. For more 
information read the Help> MSP430 IAR Embedded Workbench® IDE User Guide. 
The most convenient way is usually to set breakpoints interactively, simply by positioning the 
insertion point in or near a statement and then choosing the Toggle Breakpoint command. 
 
Set a breakpoint on a statement using the following procedure: First, click the twofact.c tab in the 
editor window and click in the statement to position the insertion point. Then choose 
Edit>Toggle Breakpoint.  
Alternatively, click the Toggle Breakpoint button on the toolbar. 
 
A breakpoint will be set at this statement. The statement will be highlighted and there will be a 
big red dot in the margin to show that there is a breakpoint there. 
 



To view all defined breakpoints, choose View>Breakpoints to open the Breakpoints window. 
You can find information about the breakpoint execution in the Debug Log window. 
 

2.6. Executing up to a breakpoint 
To execute your application until it reaches the breakpoint, choose Debug>Go. Alternatively, 
click the Go button on the toolbar. 
 
The application will execute up to the breakpoint you set.  
Select the breakpoint and choose Edit>Toggle Breakpoint to remove the breakpoint. 
 

2.7. Debugging In Disassembly Mode 
Debugging with C-SPY is usually quicker and more straightforward in C/C++ source mode. 
However, if you want to have full control over low-level routines, you can debug in disassembly 
mode where each step corresponds to one assembler instruction. C-SPY lets you switch freely 
between the two modes. 
 
First reset your application by clicking the Reset button on the toolbar. 
 
Choose View>Disassembly to open the Disassembly window, if it is not already open. You will 
see the assembler code corresponding to the current C statement.  
Try the different step commands also in the Disassembly window. 
 

2.8. Monitoring Registers 
The Register window lets you monitor and modify the contents of the processor registers. Notice 
registers PC (Program Counter), SP (Stack Pointer), SR (Status Register), R4-R15 (general-
purpose registers), CYCLECOUNTER (this is actually not a real register, rather it serves as a 
clock cycle counter so you can determine the number of clock cycles each instruction takes to 
execute; it can also be used to determine execution time of functions are whole programs).  
 

 
Figure 13.  Register window. 

 
 

Choose View>Register to open the Register window. 
 
Step Over to execute the next instructions, and watch how the values change in the Register 
window. 
 



Close the Register window. 
 

2.9. Monitoring Memory 
The Memory window (Figure 14) lets you monitor selected areas of memory. You can select 
RAM, flash, or SFR portion of the memory.  Similarly you can select View->Stack option to 
inspect the current state of the program stack.  

   

 
Figure 14.  Memory window. 

 
To display the memory contents as 16-bit data units, choose the x2 Units command from the 
drop-down arrow menu on the Memory window toolbar. 
 
If not all of the memory units have been initialized yet, continue to step over and you will notice 
how the memory contents will be updated. 
You can change the memory contents by editing the values in the Memory window. Just place 
the insertion point at the memory content that you want to edit and type the desired value. 
Close the Memory window. 
 



2.10. Viewing Terminal I/O 
Sometimes you might need to debug constructions in your application that make use of stdin and 
stdout without the possibility of having hardware support. C-SPY lets you simulate stdin and 
stdout by using the Terminal I/O window. 
 
Note: The Terminal I/O window is only available in C-SPY if you have linked your project using 
the output option With I/O emulation modules. This means that some low-level routines will be 
linked that direct stdin and stdout to the Terminal I/O window. 
 
Choose View>Terminal I/O to display the output from the I/O operations. 
 

 
Figure 15.  Terminal I/O window. 

 
The contents of the window depend on how far you have executed the application. 
 

2.11. Reaching Program Exit 
To complete the execution of your application, choose Debug>Go. 
 
Alternatively, click the Go button on the toolbar. 
As no more breakpoints are encountered, C-SPY reaches the end of the application and a 
program exit reached message is printed in the Debug Log window. 
 



 
Figure 16.  Debug Log window (bottom). 

 
If you want to start again with the existing application, choose Debug>Reset, or click the Reset 
button on the toolbar.  
 
To exit from C-SPY, choose Debug>Stop Debugging. Alternatively, click the Stop Debugging 
button on the toolbar. The Embedded Workbench workspace is displayed.  
 
 

3. Assignment 
 
Assignment #1: Write a C/C++ program that will print all prime numbers smaller than 1000 in 
Terminal I/O.  What is program execution time in clock cycles?  Could you further optimize 
your code?   
 
Assignment #2: Write a C/C++ program that will print sizes and ranges of common data types 
including char, short int, int, long int, unsigned int, unsigned long int. 


